1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1.4 1.7 Can Run Under Php5.2.6-1 ?

Discussion in 'Installation Specific Questions' started by carlo75, Mar 20, 2015.

  1. carlo75

    carlo75 Design & Development

    Hi all,
    I'm trying to update some site to latest version of Hotaru but there are a lot of tunes before, on custom made, custom plugin and other things like that. I would like to know if 1.7 can run under php5.2.6-1 ?
     
  2. valMETNG

    valMETNG Administrator Staff Member Admin

    If you're going through the effort of updating to 1.7, is there a particular reason you want to stay on such an outdated version of PHP? I'm running PHP 5.6 now and Hotaru v1.7 smokes it's so fast. Does your hosting provider only provide up to PHP 5.2?
     
  3. carlo75

    carlo75 Design & Development

    Hi Val,
    at the moment my hosting can only provide 5.2 version of php, and I've made a lot of customization. I've some problems to move all on 1.7 version and actually I'm trying to understand the better way to do that.
     
  4. valMETNG

    valMETNG Administrator Staff Member Admin

    First things first: you need to get off that hosting provider. I just switched mine to A Small Orange a few weeks ago and they have a $5/month plan that is very fast (and if you use that link, you'll get 15% off in addition). Then you can use PHP 5.6 and save yourself loads of problems.

    As you have problems with the customizations, post them here and we can troubleshoot. You do not want to stay on an old version of PHP (if only to avoid the security issues and significantly reduced speed) and Hotaru 1.7 has a ton of great new functionality and a significantly improved look-and-feel. In fact, you might find you don't even need many of the customizations after moving to 1.7. My site was highly customized, but I was able to reduce some of my customizations when moving to 1.7. (If you want to see it, send me a PM and I'll give you the site URL.)
     
  5. valMETNG

    valMETNG Administrator Staff Member Admin

    I also just noticed a 15% coupon, which may be in addition to the 15% you get from the link. Trying putting in FRIENDME when you signup as a coupon/promotional code and you might be able to get 30% off hosting. $3.50/month for a very fast service and PHP 5.6 should be a no-brainer.
     
  6. carlo75

    carlo75 Design & Development

    The best update I can use is the following:

    Debian 7
    Php 5.4
    Apache 2.2

    Can be enough for running 1.7?
     
  7. valMETNG

    valMETNG Administrator Staff Member Admin

    PHP 5.4 works. When I initially upgraded to 1.7, I had 5.4. Although the difference in speed between 5.4 and 5.6 is pretty dramatic - I'm seeing a 50% increase in speed.
     
    shibuya246 likes this.
  8. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    yes, 5.4 is fine. I think I tested down to 5.3 for the v.1.7 release.
     
  9. carlo75

    carlo75 Design & Development

    Ok, I'll try a first step
    Upgrading php 5.4
    Then upgrade HCMS to 1.7
     

Share This Page