1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Download Hotaru Cms Core 1.7.3

Main Core code for Hotaru CMS

  1. Sv9t

    Sv9t Active Member

    Hi! In Hotaru ver. 1.7.3 my posts are without pictures. Instead of them there is a link. Help me!
     

    Attached Files:

    • 123.jpg
      123.jpg
      File size:
      167.9 KB
      Views:
      8
  2. valMETNG

    valMETNG Administrator Staff Member Admin

    That might be because the image file doesn't exist in the directory. Can you make sure that the image files are actually there?
     
  3. Sv9t

    Sv9t Active Member

    no, file stored in the directory. I can open a photo, but on the my site only link
     

    Attached Files:

    • 234.jpg
      234.jpg
      File size:
      82.5 KB
      Views:
      6
  4. valMETNG

    valMETNG Administrator Staff Member Admin

    Odd. Can you please give me the URL of your site (or PM me if you don't want to post here)?
     
    shibuya246 likes this.
  5. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    nothing for images should have changed from 1.7.2 - 1.7.3. which version were you using before?
     
  6. Sv9t

    Sv9t Active Member

    i send message you
    I previously used ver. 1.7.2 - photos displayed on the site
     
  7. carlo75

    carlo75 Design & Development

    @shibuya246 can you indicate what files are changed after 1.7.3 due to the big customization on some sites?
     
  8. valMETNG

    valMETNG Administrator Staff Member Admin

    I personally find the easiest and quickest way to do this is with WinMerge. The original WinMerge project was abandoned, but there are other forks that remain current. This is the one I use.
     
  9. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    There were not a lot of changes, but a few minor ones that were significant enough to warrant a small release

    1. the javascript files were brought out of being hardcoded in Hotaru.php and set as strings that can be updated later in Initialize.php, then referenced back in Hotaru.php
    later these strings can be written to a file or db cache for allowing admins to update them themselves more easily

    2. there was a problem with paging of contents on sites after making a fix previously to allow SSL sites to use paging. I had to revert that fix until a better alternative can be found for ssl sites, as the fix had broken the original paging.

    3. the js folder on themes was not getting added into the combined js cache file and so that was fixed

    4. there was a small error on pluginsettings which got fixed

    5. an edit button was removed on pages admin for later coding
     
  10. valMETNG

    valMETNG Administrator Staff Member Admin

    I just submitted a post on your site for hotarucms.org with an image and it worked fine. I also submitted http://www.handmade4dolls.com/2013/06/blog-post_552.html as a test post in my base build and it worked fine. I then submitted http://www.handmade4dolls.com/2013/06/blog-post_552.html (that you submitted previously) on your site and the image worked. So we need to figure out how you submitted these posts and images previously that's different from what I just did.
     
  11. valMETNG

    valMETNG Administrator Staff Member Admin

    We did a bunch of troubleshooting and it appears there are a couple of issues with the post_images plugin and Cyrillic, but it comes down to encoding and exceeding the maximum filename length. To correct the problems, the following lines need to be changed in /plugins/post_images/post_images.php:

    Line 257:
    Code:
    $image_name = truncate(preg_replace('/\W+/','_',$h->vars['submitted_data']['submit_title']), 15) . '_' . str_replace('.','_',microtime(true)) . '.jpg';
    Line 98:
    Code:
    $h->post->vars['img'] = isset($h->post->post_img) ? urlencode($h->post->post_img): null;
     
    shibuya246 and Sv9t like this.
  12. squidy21

    squidy21 Active Member

    How to fix it?
    Notice: Undefined index: tags_setting_display_buttons in .../.../content/plugins/tags/templates/tags.php on line 30

    $displayButtons = $h->vars['tags_settings']['tags_setting_display_buttons'];

    I use tag 2.0
     
  13. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    do you have a link to your site i can check? PM is ok
     
  14. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    Also, what version of Hotaru are you using? I think you need at least v.1.7.0 for tag 2.0 to work
     
  15. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    did you have a fix for this already or should I check?
     
  16. squidy21

    squidy21 Active Member

    PM was sent.
    I use hotaru 1.7.3
    :D
     
  17. valMETNG

    valMETNG Administrator Staff Member Admin

    I believe the two fixes posted related to line 257 and line 98 fixed the problems, so these should be changed in the plugin.
     
  18. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    thanks. have updated and released
     
    Sv9t and valMETNG like this.
  19. squidy21

    squidy21 Active Member

    I have another problem

    PHP Warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'OR OR ) ORDER BY post_date DESC LIMIT 5' at line 1 : SELECT * FROM hotaru_posts AS P LEFT OUTER JOIN hotaru_users AS U ON P.post_author = U.user_id WHERE post_archived != 'Y' AND post_id != 115 AND post_type = 'news' AND (post_status = 'top' OR post_status = 'new') AND ( OR OR ) ORDER BY post_date DESC LIMIT 5 in /libs/extensions/ezSQL/mysqli/ez_sql_mysqli.php on line 313

    PHP Notice: Undefined index: users_meta_description_results_before in .../content/plugins/users/users.php on line 211
    PHP Notice: Undefined index: users_meta_description_results_middle in .../content/plugins/users/users.php on line 211
    PHP Notice: Undefined index: users_meta_description_results_after in .../content/plugins/users/users.php on line 211
    PHP Notice: Undefined index: users_profile_meta_keywords_more in .../content/plugins/users/users.php on line 212
    PHP Notice: Undefined index: users_profile in .../content/plugins/users/templates/users_navigation.php on line 163
    PHP Notice: Undefined index: users_all_posts in .../content/plugins/bookmarking/bookmarking.php on line 646
    PHP Notice: Undefined index: users_all_comments in .../content/plugins/comments/comments.php on line 457
    PHP Notice: Undefined index: users_profile in .../content/plugins/users/users.php on line 84
    PHP Notice: Undefined index: users_default_meta_description_before in .../content/plugins/users/users.php on line 195
    PHP Notice: Undefined index: users_default_meta_description_after in .../content/plugins/users/users.php on line 195
    PHP Notice: Undefined index: users_profile_meta_keywords_more in .../content/plugins/users/users.php on line 199
    PHP Notice: Undefined index: users_profile in .../content/plugins/users/users.php on line 249

    :(

    And how to make footer from custom theme?
     
  20. valMETNG

    valMETNG Administrator Staff Member Admin

    The first warning is coming from /libs/Database.php and, from the looks of the error, has something to do with the "( OR OR )" as that isn't valid SQL. Did you add any bookmarking filters recently? If so, they are probably empty. You should check the filters aren't empty before you add them.

    The other notices might be the result of the filter problem. Did they occur at about the same time as the first error? If so, they are likely related and, if you fix the filter problem, you will fix those.

    You can modify the footer by copying over the default theme to a custom theme directory (winks at @shibuya246) and then changing the file footer.php.
     

Share This Page