1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Download Hotaru Cms Version 1.6.0

Discussion in 'News and Announcements' started by shibuya246, Sep 19, 2014.

  1. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    There was a plugin here
    http://forums.hotarucms.org/threads/whos-online-0-2.359

    but I am not sure of its status or whether it worked well. I seem to remember the counts may have been off a bit

    we could rework this idea and produce an update. also show the online count in the admin page ?

    What is the url for your site again?
     
  2. robin007

    robin007 Well-Known Member

    Now I am not using online.
    because post submition step 2 Gets csrf error.
     
  3. robin007

    robin007 Well-Known Member

    main page online count affect the members join.
    guest see this online users and assume this is not a popular site.
     
  4. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    if you turn off post_images plugin you will not get that error
    I am working on an update for post_images plugin to remove the error also
     
  5. robin007

    robin007 Well-Known Member

    OK thank you.
     
  6. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    I put out new version of Hotaru CMS core including required fix for post images plugin
    please try this and let me know if CSRF is all fixed up for post images submit step2
    thanks
     
  7. squidy21

    squidy21 Active Member

  8. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

  9. squidy21

    squidy21 Active Member

    Still errors, i was turn off debug mode to hide it.:(
     
  10. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    squidy21 likes this.
  11. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    Looking at your plugin list, you have Post Manager version 0.9. There is a blue highlight on it. The latest plugin is v 1.0 which should fix the problem you are experiencing
    http://forums.hotarucms.org/threads/post-manager-1-0.177/

    After uploading this you may get 1 error coming through which I have already fixed in the core Hotaru files. That will be out in v.1.6.4
     
    squidy21 likes this.
  12. squidy21

    squidy21 Active Member

    Ok, thank, I was installed it to my web.:D
     
    shibuya246 likes this.
  13. robin007

    robin007 Well-Known Member

    Admin page=>Help=>Core plugins - link broken.
    Top Right=>Profile link broken.
     
    shibuya246 likes this.
  14. slepua

    slepua Member


    Hello, shibuya,

    Just wanted to ask if this was eligible for an upgrade from 1.5.2. I just did an upgrade from 1.5.2RC to 1.6.6 following all the steps but my site is totally messed up now :( Thinking of doing a backup.

    could you take a look at http://realitycracked.com ?

    Problems:
    1.)I get a big error:
    Internal Server Error
    Undefined index: bookmarking_all

    2.) My profiles are all messed up, can't enter the profile page, cant login, there is no menu at the top of the page.

    3.) admin backend is also all messed up,
    I have errors like
    Undefined index: users_admin_stats_users

    Should I do a back-up to an old version or its fixable?
    I just don't want to lose everything so I will rather stay on old version..
     
  15. slepua

    slepua Member

    Turned on debug mode... Its full of errors like

    Notice: Undefined index: HALT in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1107 Notice: Undefined index: VERB in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1044 Notice: Undefined index: PATH in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1044 Notice: Undefined index: DEBUG in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1050 Notice: Undefined index: HIGHLIGHT in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1062 Notice: Undefined index: HALT in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1107 Notice: Undefined index: VERB in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1044 Notice: Undefined index: PATH in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1044 Notice: Undefined index: DEBUG in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1050 Notice: Undefined index: HIGHLIGHT in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1062 Notice: Undefined index: HALT in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1107 Notice: Undefined index: VERB in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1044 Notice: Undefined index: PATH in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1044 Notice: Undefined index: DEBUG in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1050 Notice: Undefined index: HIGHLIGHT in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1062 Notice: Undefined index: HALT in /home/realityc/domains/realitycracked.com/public_html/Hotaru.php on line 1107
    etc..

    and

     
  16. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    thanks. the problem is some code in the main hotaru.php file that we don't need. If we remove that most of the errors will go
    let me try and identify the code to delete

    standby
     
  17. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    First lets delete lines 1042 - 1108 in Hotaru.php
     
  18. slepua

    slepua Member

    I see you are online on my site. Do you want me to turn on debug mode for you so you see all the errors or admin rights or something?
     
  19. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    yes, please
     
    slepua likes this.
  20. slepua

    slepua Member

    Deleted those lines and apparently it fixed some issues. Although admin backed still looks totally wrong and menu at the top is wrong and profiles are wrong.

    Turned on debug mode but they aren't showing any errors now :/ weird.

    Wait a moment I will create admin acc for you to see for yourself.
     

Share This Page