1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1.7 Error 404 After Friendly Url

Discussion in 'General Troubleshooting' started by masih, Jan 30, 2016.

  1. masih

    masih New Member

    Hi ,

    i tried to active Friendly URL and change htaccess file to >> .htaccess

    admin url and submit url works fine , BUT when i submit a new link (source) in bookmarking plugin , new post link show Error 404 .

    see this : http://bigg.ir/all/
    it work true , BUT when go to one of the posts : http://bigg.ir/کوتاه-کننده-لینک-پی-دی-وان/

    it show Error 404! WHY ?!

    i'm tried to solve this problem with search in forum , but i don't find anything to fix this error .

    anybody can help me ?


    "" MY language is PERSIAN ''" maybe problem is with my language , but when i turnOff the friendly URL , post link opened fine!
     
    Last edited: Jan 30, 2016
  2. masih

    masih New Member

    maybe this replay help you to fix this problem :

    Tag link and Category links work fine with friendly url !

    so WHY post links have problem ?!
     
    Last edited: Jan 30, 2016
  3. valMETNG

    valMETNG Administrator Staff Member Admin

    Welcome to Hotaru. Sorry you're having this problem. This might be similar to what was discussed in this thread. Can you try to add the following on line 661 of /libs/extensions/ezSQL/ez_sql_core.php:
    Code:
    $query = str_replace('%', '%%', $query);
     
    masih likes this.
  4. masih

    masih New Member

    Thanks For replay , i just do it and now i see this error in top of every pages :

    Warning: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '%s LIMIT 1' at line 1 : SELECT miscdata_value FROM hotaru_miscdata WHERE miscdata_key = %s LIMIT 1 in /home/****/public_html/****/libs/extensions/ezSQL/mysqli/ez_sql_mysqli.php on line 313

    --------------------------------
    this code just down my site! maybe i can't do this steps Properly . can you edit this file and give me, Please ?
    I'm So sorry :)
     
    Last edited: Jan 31, 2016
  5. masih

    masih New Member

    Oh Boy!!! @valMETNG
    all of my contents and setting is Missed!!!
    i can't see any settings , content , menus , categories and nothing!

    what's happened ?!
    i just reUpload ez_sql_mysqli.php file from fresh downloaded to my File manager and every thing is missed.

    ---------------------

    But in "PHPmyAdmin" , i can see categories and other settings . SO ... ?!!!
     
  6. valMETNG

    valMETNG Administrator Staff Member Admin

    Oooppss. Don't worry - we'll get this working :)

    Here's the file with the change made, so you can try and copy this over the other one. If this doesn't work, would you please PM me your admin login credentials (don't post it here in this thread)? I'll see if I can figure out the problem.
     

    Attached Files:

    masih likes this.
  7. masih

    masih New Member

    No! it's does not working again .
    i must reTry install Hotaru CMS again . i think it can help me .

    and after installed , i don't use Friendly url . enemy url is better than friendly url that destroy all of my settings :D
     
  8. valMETNG

    valMETNG Administrator Staff Member Admin

    Sorry that didn't work and I understand why you'd want to turn friendly URLs off. I don't know how search engines (and SEO) work with Persian but, assumingly, friendly URLs are better for your site. So if you want to try again at some future point, I promise you we'll figure out and solve the problem.
     
    masih likes this.
  9. masih

    masih New Member

    your welcome valMETNG . search engines index and show Persian URLs property . i'm hope if i reinstall Hotaru , we can solve this problem . because if this problem don't fix , some of languages (Persian , Arabic , Afghanistan , Turkish , Egypt and etc) have this problem and Horaru can't get more popularity in some countries .

    i trying to solve this and then share fix steps with you .
     
    valMETNG likes this.
  10. valMETNG

    valMETNG Administrator Staff Member Admin

    I think I may have found the problem. It actually is a bug identified here (having to do with double encoding) that appears never got updated in the latest version. After you do your reinstall, would you please change line 402 of /libs/Post.php to:
    Code:
    $post_id = \Hotaru\Models2\Post::getFirstPostByPostUrl($h, $url);
    @shibuya246: do you have any pending updates for the latest version? It appears this one didn't make it in.
     
    hilmwa, shibuya246 and masih like this.
  11. masih

    masih New Member

    And Fine! i change this in XAMPP (localhost) and now it solve the problem .
    good job
     
    shibuya246 and valMETNG like this.
  12. valMETNG

    valMETNG Administrator Staff Member Admin

    Great to hear and apologies that didn't get rolled in sooner. Thanks for pointing out the problem.
     
    shibuya246 and masih like this.
  13. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    looks like that got missed. will check tonight and add in. thanks
     
  14. hilmwa

    hilmwa New Member

    I did these two changes, but it didn't fix it for me

    Any other ideas?
     
  15. valMETNG

    valMETNG Administrator Staff Member Admin

    Welcome to Hotaru. Sorry you're having this problem. Can you tell us please which two changes you made? Also, if there are any errors in your error_log, would you please post them here? Thanks.
     
  16. hilmwa

    hilmwa New Member

    Thanks valmetng for your prompt response! I just fixed it. Apparently .htaccess wasn't created when I did my install. I created one using the default and it fixed it.
     
    valMETNG likes this.

Share This Page