1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

From Http To Https

Discussion in 'Help Wanted' started by SaadKS, Dec 9, 2017.

  1. SaadKS

    SaadKS New Member

    shibuya246 likes this.
  2. valMETNG

    valMETNG Administrator Staff Member Admin

    Congratulations on your progress.

    The three major changes I think will help your results include:
    1. Make sure BASEURL in /config/settings.php starts with https://
    2. Change line 104 of Paginator.php to:
      Code:
      $path = "//" . $host . $uri;
    3. Make sure your .htaccess has code that forces https, something like:
      Code:
      ## if they go to www, remove www
      RewriteCond %{SERVER_PORT} !^443$
      RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
      RewriteRule ^(.*)$ https://%1/$1 [R=301,L]
      
      RewriteCond %{SERVER_PORT} ^443$
      RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
      RewriteRule ^(.*)$ https://%1/$1 [R=301,L]
     
    shibuya246 likes this.
  3. SaadKS

    SaadKS New Member

    Thank You @valMETNG ! I completed the first 2 steps... Now about the 3rd... You mean the .htaccess of the main root, right? (/public_html)
     
  4. valMETNG

    valMETNG Administrator Staff Member Admin

    That's correct. This will just force all requests to go secure.
     
  5. SaadKS

    SaadKS New Member

    Done!! No mixed content, but I see this "Your webserver is not forcing the use of SSL."
    I noticed that there is an unsafe script in registration area... Should I uninstall and reinstall the captcha?
     
    valMETNG likes this.
  6. valMETNG

    valMETNG Administrator Staff Member Admin

    Glad that worked but odd that the htaccess code isn't forcing secure. That's the code I use on my site and it does work but it appears whynopadlock is suggesting this code instead:
    Code:
    RewriteCond %{HTTP_HOST} ivirality\.net [NC]
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://ivirality.net/$1 [R,L]
    So you can try that instead of the code I suggested above.

    Where are you seeing an unsafe script in the registration area? I do notice in your right column:
    Chat
    {literal} {/literal}

    That probably means you've got some bad code for your chat app in your widget. If memory serves, that's notation in Smarty (which isn't used in Hotaru). So that might be what is causing the problem.
     
  7. SaadKS

    SaadKS New Member

    Same issue! Nothing changed! I see the 'unsafe scripts" warning in registration and admin panel...
     
  8. SaadKS

    SaadKS New Member

    I forgot it!! I will delete it! Either way it's not worthy! :D
     
  9. valMETNG

    valMETNG Administrator Staff Member Admin

    Of course I can't see your admin panel but I don't see any error on your registration page. Is the error shown on the page itself?
     
  10. SaadKS

    SaadKS New Member

    Error is shown on the admin page and registration... I disabled the widget, but I don't remember how to delete it... Apart from that, I noticed that I have around 10 new users... I don't see any activity.. They look like spammers... Is the error related to them?
     
  11. valMETNG

    valMETNG Administrator Staff Member Admin

    It's really hard for me to determine given I can't see what you're looking at. Additionally, I just went to https://ivirality.net/register/ and see it's now 404ing (so you're probably doing some troubleshooting). Can you post a screen shot of the error on the page? If you have 10 new users without any advertising or other activity, it's highly likely a spammer/bot.

    If you're comfortable doing so, you can also PM me (don't post publicly here) your admin credentials (please change your password afterwards). I'll log in and see if I can figure it out from there.
     
  12. SaadKS

    SaadKS New Member

    To be honest, I pressed by mistake "delete database cache"! Now all urls are a 404 error!!
     
  13. valMETNG

    valMETNG Administrator Staff Member Admin

    SaadKS likes this.
  14. SaadKS

    SaadKS New Member

    After I uninstalled/installed the Captcha, I did the same for Users and User Sign In... After that I pressed the delete database cache button! :(
     
  15. valMETNG

    valMETNG Administrator Staff Member Admin

    That makes more sense - I'm betting the Users and User Sign In plugins are out of order. Please confirm at that link above.
     
    SaadKS likes this.
  16. SaadKS

    SaadKS New Member

    I think everything is out of order... When I deleted the "Chat" widget, I uninstalled the Text Widget as well... I think I will uninstall all plugins!
     
  17. SaadKS

    SaadKS New Member

    What about my posts and categories? Will they be deleted?
     
  18. SaadKS

    SaadKS New Member

    UPDATE:

    1) In my SSL area (in my hostinger account) there is a "force https" button, which I didn't press... I pressed it, I checked my site with whynopadlock.com and I see no issues with https!

    2) I uninstalled ALL plugins and installed them again in the correct order... Same issue... All links are error 404!
     
  19. valMETNG

    valMETNG Administrator Staff Member Admin

    Doing a search, I found this post and this post that refer to 404 errors. Can you see if either of those help? Also, are there any errors in your error_log? Since everything is broken except your home page, this leads me to believe it's an .htaccess problem. Would you please post your .htaccess file?
     
    SaadKS likes this.
  20. SaadKS

    SaadKS New Member

    I downloaded my .htaccess file, but I see a blank page which I can't upload... What should I do? I see some errors in error_log.php from 10/12, the day this issue started...
     

Share This Page