1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hotaru Pre-beta 0.8 testing bug report thread

Discussion in 'General Troubleshooting' started by nothingman, Nov 7, 2009.

Thread Status:
Not open for further replies.
  1. nothingman

    nothingman Active Member

    2 Quick questions (apologies if this is the incorrect thread).
    - I've activated all the sidebar widgets, how do I go about having them displayed in the sidebar of the main site? For example, the "Sidebar Comments" plugin? Do I need to do this.
    - How do I go about removing the "A New Sidebar" and "Hello Universe!" thingies from the sidebar and homepage?
     
  2. JonH

    JonH Admin & Design

    In response to Nick's thread here, I figured I would start this thread under the "Core" forum for any small bug reports.

    You can get 0.8 from the SVN trunk - Tortoise SVN will do it all for you.

    (I moved nothingman's post to here but since nothingman's post time was before mine it's 1st)
     
    carlo75 and nothingman like this.
  3. Nick

    Nick Well-Known Member

    Okay, that's an easy one. Go to Plugin Management and uninstall the "Hello Universe" plugin. That will solve both problems! :cool:
     
    nothingman likes this.
  4. nothingman

    nothingman Active Member

    Thanks Jon, thanks Nick.

    Some feedback (with a query):-

    1. I used the upgrade option and I got the following error after completing the installation.

    [​IMG]

    2. I'm not sure if the following could be called a bug but the header formatting looked liked this after a fresh install. Clearing the FF cache solved it for me BTW

    [​IMG]

    3. When I use ONLY one smiley on the comment form, the comment does not appear. But if i use a smiley along with some text (or use two smileys for a comment), the comment appears.

    4. How does one go about using gravatar? I installed the Gravatar 0.6 plugin, but when I clicked Account on the home page, all I got were options for changing my email add, password etc. :confused:
     
    Last edited: Nov 7, 2009
  5. Nick

    Nick Well-Known Member

    1. Reinstalling the Submit plugin should fix that.

    2. The real question is what does a regular user see? We can't expect them to clear their browser cache, so I'm not sure about this yet...

    3. Do you have Akismet installed and active? Maybe Akismet is catching those single smilies? Check Comment Manager to see if the comment is pending.

    4. Gravatar is an admin option, not a user option. Check the Submit and Comments setting pages. If the user's email is registered with Gravatar, their avatar will show. Don't forget to check your avatar rating as mentioned here. If your avatar is rated PG or above, you will need to change the rating setting in the gravatar.php file itself.
     
  6. nothingman

    nothingman Active Member

    I have installed Akismet but it is disabled/inactive (unchecked). I checked Comment Manager, and the status of the 'single smiley' comment was pending. Would this mean that I need to uninstall Akismet? (My assumption is that having Enable or disable Akismet for posts unchecked under Akismet Settings means that it is disabled/inactive :-/

    Thanks, I got it working now.
    ==========
    EDIT 1:

    5. Is there a way for the admins to manage users (like say, reset a user's password, change a user's email address etc)?

    EDIT 2:

    6. The profile page for a user on the main hotaru demo page looks quite different from the one on my test site. For example, the gravatar of the user and the Latest Activity sections are missing on the "user profile" page of my test site. Are these unavailable for this release? :-?
     
    Last edited by a moderator: Nov 8, 2009
  7. Nick

    Nick Well-Known Member

    3. Akismet - Okay, I can confirm that's a bug. Ticket #57

    4. Does your avatar show up in the Gravatar Verification Tool?

    5. To edit a user's name, email address or role, click their name, then click Account. You can also access their account in the User Manager. You can't edit someone's password, you can only edit your own. A user can change their own password or get a new one from the log in page if they forget it. See attached screenshot.
     

    Attached Files:

  8. Nick

    Nick Well-Known Member

    6. Go to Admin -> Maintenance, clear the database cache and then reload your profile page. That should fix it.
     
  9. Nick

    Nick Well-Known Member

    Latest updates:

    - Fixed the Akismet enable/disable problem.
    - Got smilies showing in Comment Manager and Sidebar Comments.
    - Added the posting time to comments in Comment Manager instead of just the date.
    - Made Gravatar use just one image for the default avatar (instead of 6 images of different sizes) and it now check's your theme's images folder for the avatar before defaulting to the Gravatar folder.
    - Made Akismet report posts as ham or spam to the Akismet server whenever a post's status is changed or a post is deleted (it only did this with comments before). This means that if lots of people use Hotaru, then we can train Akismet to correctly mark posts and comments as ham or spam.

    Those updates are on the SVN trunk. If you update your files (no need to reinstall or upgrade), you will need to reinstall the Akismet and Smilies plugins so their new plugin hooks get registered.

    Thanks for the feedback. Keep it coming!

    Edit: Changed "Account" in the navigation bar to show the user's avatar and name. Reinstall the Users and Gravatar plugins after updating your files to commit #578.
     
  10. Nick

    Nick Well-Known Member

    Changeset #581/582: Caching and other changes to cut database queries down from 400+ to less than 100. There's a new cache folder called "html_cache". You need to give it write permissions.

    Update:

    Changeset #583/584: Fix for user_ip mistake in the updateUser function. Fix for pending posts being visible to users without global post edit permissions. Added pending counts for Post, User and Comment Manager plugins. New "Stop Spam" plugin.
     
    Last edited: Nov 10, 2009
  11. carlo75

    carlo75 Design & Development

    Hi Nick,
    when I try to post a news, on demo site I receive this error on header:

    Warning: Hotaru::include_once(/home/hotarorg/public_html/demo/install/install_language.php) [hotaru.include-once]: failed to open stream: No such file or directory in /home/hotarorg/public_html/demo/libs/Hotaru.php on line 247

    Warning: Hotaru::include_once() [function.include]: Failed opening '/home/hotarorg/public_html/demo/install/install_language.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/hotarorg/public_html/demo/libs/Hotaru.php on line 247

    Warning: Hotaru::include_once(/home/hotarorg/public_html/demo/install/install_language.php) [hotaru.include-once]: failed to open stream: No such file or directory in /home/hotarorg/public_html/demo/libs/Hotaru.php on line 247

    Warning: Hotaru::include_once() [function.include]: Failed opening '/home/hotarorg/public_html/demo/install/install_language.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/hotarorg/public_html/demo/libs/Hotaru.php on line 247

    bye
     
  12. Nick

    Nick Well-Known Member

    Ah, thanks for that. It's fixed on my offline site, but there's a problem with caching in the sidebar that I need to fix before uploading the changes.

    Edit: Hmm, fixed those, but now I see another problem with categories missing from urls...
     
  13. carlo75

    carlo75 Design & Development

    No problem,
    when I edit the news I receive this error instead:


    Warning: Hotaru::include_once(/home/hotarorg/public_html/demo/install/install_language.php) [hotaru.include-once]: failed to open stream: No such file or directory in /home/hotarorg/public_html/demo/libs/Hotaru.php on line 247

    Warning: Hotaru::include_once() [function.include]: Failed opening '/home/hotarorg/public_html/demo/install/install_language.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/hotarorg/public_html/demo/libs/Hotaru.php on line 247

    Warning: Hotaru::include_once(/home/hotarorg/public_html/demo/install/install_language.php) [hotaru.include-once]: failed to open stream: No such file or directory in /home/hotarorg/public_html/demo/libs/Hotaru.php on line 247

    Warning: Hotaru::include_once() [function.include]: Failed opening '/home/hotarorg/public_html/demo/install/install_language.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/hotarorg/public_html/demo/libs/Hotaru.php on line 247

    Warning: Cannot modify header information - headers already sent by (output started at /home/hotarorg/public_html/demo/libs/Hotaru.php:247) in /home/hotarorg/public_html/demo/content/plugins/submit/submit.php on line 377
     
  14. carlo75

    carlo75 Design & Development

    And then, when I try to comment this error:


    Warning: Hotaru::include_once(/home/hotarorg/public_html/demo/install/install_language.php) [hotaru.include-once]: failed to open stream: No such file or directory in /home/hotarorg/public_html/demo/libs/Hotaru.php on line 247

    Warning: Hotaru::include_once() [function.include]: Failed opening '/home/hotarorg/public_html/demo/install/install_language.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/hotarorg/public_html/demo/libs/Hotaru.php on line 247

    Warning: Cannot modify header information - headers already sent by (output started at /home/hotarorg/public_html/demo/libs/Hotaru.php:247) in /home/hotarorg/public_html/demo/content/plugins/comments/comments.php on line 310

    I'm unlucky today
     
  15. carlo75

    carlo75 Design & Development

    I think all issue are related with caching sidebar..
    but this is it... ;-)
     
  16. carlo75

    carlo75 Design & Development

    Now all seems to be ok.

    Nick I've tried to search only a char, and there are always 4 story submitted 14558 days ago...

    Try to search single letter like a or z
     
  17. Nick

    Nick Well-Known Member

    Yeah, it looks my caching experiments are causing all kinds of problems. Oh well, that's what testing is for! :eek:
     
  18. Nick

    Nick Well-Known Member

    I think I've got the sidebar working okay now, but I had to change the times in the Activity widget because if you cache "8 mins ago", it will always be 8 mins ago! LOL.

    I'll look at the search problem tomorrow. I suppose it should show an warning message if there's a search for less than 3 characters?

    Night all.
     
  19. JonH

    JonH Admin & Design

    Playing around in the demo's admin section I was in the 'Vote Simple' plugin settings and when I unchecked or checked "Enable Alerts (i.e. flag / bury). Alerts are only used on "new" posts" I had to save twice for it to take.

    I haven't checked yet if this is admin wide or just that plugin, I know other plugins used to not do this with 0.7.5
     
  20. Nick

    Nick Well-Known Member

    Okay, the latest commits to the SVN and demo include fixes for search and plugin settings, and username/password tips on the registration page. :cool:
     
Thread Status:
Not open for further replies.

Share This Page