1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I cant submit any link

Discussion in 'How-To and Troubleshooting' started by download, Mar 17, 2010.

  1. download

    download New Member

    http://www.websitefor.info/deals/

    First of all I would like to know if my page looks normal after installation and with the theme. I dont have any posts. But when I tried to add a link, it says "Nothing submitted"...

    what am i doing wrong?

    thank you.
    san
     
  2. carlo75

    carlo75 Design & Development

    Hi san, have you enabled the right plugin Submit or Submit Light?
     
  3. Nick

    Nick Well-Known Member

  4. hangbowl

    hangbowl New Member

    Yup, as Nick say. Follow the Step-by-step first plugin installation. i've got so many problem when I not follow it. even one plugins :))
     
  5. download

    download New Member

    thank you all ... I would let u know the end result after I reinstall the plugins... FYI: i have submit 2.1 and submitlight0.3 enabled..

    thank you so much
    San
     
  6. Nick

    Nick Well-Known Member

  7. download

    download New Member

    I uninstalled the entire plugins and installed them back according to the directions. still the problem exist. My host is godaddy. here is the php info

    http://www.websitefor.info/deals/info.php

    I am not submitting any japanese characters.
     
  8. Nick

    Nick Well-Known Member

    Your version of PHP is 5.2.5.

    I don't know if that's the reason for your problem, but there's a good chance.
     
  9. idigital

    idigital New Member

    I'm having this problem as well, and I followed the plugin install guide.

    I'm using php 5.2.8 and mysql 5.1.30, and testing with xampp which has an iconv folder in the apache folder. And I'm not using any foreign characters.

    So, help! Itching to play with this system!
     
    Last edited: Mar 19, 2010
  10. Nick

    Nick Well-Known Member

    The only way we can find the cause is if people experiencing the problem (like yourself) get into the code and run some tests to try to identify where it's going wrong.

    Good luck sir, we are counting on you! :D
     
  11. idigital

    idigital New Member

    I tried my best to no avail, so installed it on a test server and now it works \o/
     
  12. Nick

    Nick Well-Known Member

    Hi idigital, glad to hear you got it working in a different environment. I wonder if you'd still be interested in helping us troubleshoot the problem?

    What I'd like to know is whether you can get to submit step 2 after making this change:

    Open content/plugins/submit/libs/SubmitFunctions.php and find line 692:

    PHP:
    public function fetchTitle($url)
    {
        require_once(
    EXTENSIONS 'SWCMS/class.httprequest.php');
    Please change it to this:

    PHP:
    public function fetchTitle($url)
    {
         return 
    false;
         require_once(
    EXTENSIONS 'SWCMS/class.httprequest.php');
    Obviously that will mean you won't get a title, but if it allows you to proceed to step 2, then at least we know the problem is in the fetchTitle function.

    Thanks.
     
  13. idigital

    idigital New Member

    Yeah it still says nothing submitted, I tried going directly to the submit2 page as well and it also says nothing submitted.

    Gremlins!
     
  14. Nick

    Nick Well-Known Member

    Does it go to step 2 if you check "Post without a link"?
     
  15. idigital

    idigital New Member

    Nope, same problem.
     
  16. DamonW

    DamonW New Member

    I ran into this same problem. Even though i'm running WAMP with mysql and php on the same machine, the mysql time is wrong. So when the submit plugin deletes items from the temp table over 30 mins old, it's always clearing the entire table.

    I'll submit a patch for review.
     
  17. apfind

    apfind New Member

    I'm troubleshooting some problems myself... I have deactivated all the plugins and added the bare minimum according to the tutorial... Submission used to work fine but now I'm getting a blank page after I pass submission step 1. It gets hung up here "http://www.apfind.org/apfindalt/index.php?page=submit1" I also get a Csrf error when ever I try to log in with safari but log in works with Chrome. Strange. I'm working on it. Might have to start over from scratch. It used to work. :p
     
  18. Nick

    Nick Well-Known Member

    One issue I noticed after upgrading was a double set of cookies that prevented me from logging in. Look for hotaru_user and hotaru_key cookies, clear them all and try logging in again. See if that makes a difference.
     
    apfind likes this.
  19. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    For error checking, can you try opening the file /content/plugins/submit/submit.php and insert the following at line 217:

    PHP:
    // check if data has been submitted
    print "before checking submitted url<br/>";
    $submitted $funcs->checkSubmitted($h'submit1');
    print 
    "after checking submitted url<br/>";
    print 
    "submitted: " $submitted;
            
    // save/reload data, then go to step 2 when no more errors
    then we can see as a first step where the problem might be.
    I have registered on your demo site. can you let me know when this is in and i will look again?
    thanks
     
    apfind likes this.
  20. apfind

    apfind New Member

    Thanks Nick and Shibuya. :)

    Thanks for registering on my site Shibuya, I'll let you know when I make the change...
     

Share This Page