1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP Version

Discussion in 'News and Announcements' started by shibuya246, Apr 27, 2013.


What version of PHP do you have

  1. Not sure

    0 vote(s)
  2. 5.2.x

    5 vote(s)
  3. 5.3.x

    6 vote(s)
  4. 5.4.x

    2 vote(s)
  1. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    As we look to improve the stability and speed of Hotaru CMS, we need to add features that are not available in older versions of PHP. In particular we are looking to add features that require at least PHP version 5.3

    Can you tell us what version you currently have?

    If you are not sure, go to your Admin Dashboard, turn on debug and then look at the bottom of one of your sites pages in the browser. The PHP Version and MySQL version should be listed there. You can turn debug off again afterwards.
  2. narc

    narc Well-Known Member

    Have 5.3.x -> need 5.4.x = but hotaru not runnig with 5.4.x :)
    shibuya246 likes this.
  3. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    Have you tried the v.1.5.0 alpha with 5.4.x ? No problem if not. I have it running on 5.4.14 and it is not having any problems

    I will probably put out the v.1.5.0 as a build without ActiveRecord and some other features that require PHP 5.3. Then I will start release a beta for ActiveRecord libraries as v.1.6.0 which will definitely require PHP 5.3

    Anyone who is stuck between an older PHP version to satisfy the Hotaru CMS 1.4.2 code can then upgrade their Hotaru CMS first to 1.5.0, and next upgrade to PHP 5.3.x or 5.4.x, then upgrade to Hotaru CMS 1.6.0 after
  4. narc

    narc Well-Known Member

    I'm currently testing on. runs well so far, but I can not test it with my live data. hotaru fat because 2 years was no longer being developed, I had my 1.4.2 version even expand to make many, so it is no longer compatible.

    supplied in the multi-image uploads module, but I will put on the new 1.5.x version and learn the same about the new feature have.
  5. larryhill

    larryhill New Member

    How to make latest hotarucms work on PHP5.2..
  6. narc

    narc Well-Known Member

    update your php version. php 5.2 is over 5 years old.

Share This Page