1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pligg Importer 0.8

Discussion in 'Deprecated Plugins' started by Nick, Aug 16, 2009.

Thread Status:
Not open for further replies.
  1. cybertooth

    cybertooth New Member

    I hope there is a new version of this that can import big database .. I really like to convert my site into hotaru ...
  2. nothingman

    nothingman Active Member

    How big is your database? I successfully imported my pligg/swcms database of 4000+ posts and about 160000 comments.

    Export you database as mentioned in the pligg importer, install hotaru on localhost and wait - that's the key - my comments table took about an hour! If you have a slow CPU/memory, don't open any other programs and expect your CPU to be tested to its optimum! :)
    Last edited: Jun 24, 2010
  3. Nick

    Nick Well-Known Member

    @cybertooth, did you read my reply to your previous post on this subject?

  4. narc

    narc Well-Known Member

    I have a problem with the plugin. when I come to step 2 back the home of pliggimporters. I load up the links-XML file. as but nothing happens. my XML-link fire have 24MB, i install hotaru on my localhost.

    EDIT: my error log from apache

    Last edited: Aug 13, 2010
  5. petsagouris

    petsagouris Design & Development

    This error log proves that PHP can accept 8388608 bytes in size for a file upload.
    Please consult this blog entry on the subject for more details.

    Maybe set post_max_size and upload_max_filesize to around 64M on your localhost's php.ini just to get on with the conversion.
    narc and Nick like this.
  6. narc

    narc Well-Known Member

    many thanks.

    i have new problem with pligg importer.

    then click continue

    EDIT: All database tables (categories, links, comments, tags, users and votes) are after import empty.
    Last edited: Aug 13, 2010
  7. Nick

    Nick Well-Known Member


    That should be the name of your database. It sounds to me like you've got the same problem mabujo had here. The plugin hasn't been updated to work with the latest versions of phpMyAdmin. Currently the only way to use it is to downgrade phpMyAdmin before exporting your tables as XML files.

    Since this is a use-once-and-forget-it plugin, there is little motivation to keep it up-to-date, and even if we wanted to, it's a very difficult task due to phpMyAdmin's export changes. Really, the whole plugin needs rewriting so that it uses the database instead of memory to store the source data. That, though, is a big job and is unlikely to happen unless funded by Pligg users wishing to move to Hotaru.
    narc likes this.
  8. narc

    narc Well-Known Member

    thanks Nick. i have my phpmyadmin downgradet to 2.x - categories import is done, no errors. link import have many errors:
  9. Nick

    Nick Well-Known Member

    Open pliggimp_links.php and after line 105 put:

    if (!$parsed) { echo $child->link_url; exit; }
    Then you can see what url is failing.

    Edit: Remove exit; if you want to show them all.
  10. narc

    narc Well-Known Member

    new errormessage - debugmode
    is 'post_orig_url' my problem, a SQL query?
  11. Nick

    Nick Well-Known Member

    Thanks for PM'ing me your url. It helps when I can see the site. It looks like all your posts are "editorials"? If so, they don't have urls, and therefore parse_url returns a warning.

    However, it's just a warning and should not effect the import.

    When the import is complete, we can fix the editorial urls quite easily in phpMyAdmin, but first you need to finish the import. What other errors are you getting?
  12. narc

    narc Well-Known Member

    The reports are written by members of themselves. after a release of my records are provided online.

    runs through import, with the error messages. even if I wait a long time, not all imported items. I have no button then move to the next step to come.
  13. Nick

    Nick Well-Known Member

    How about trying this?

    if ($child->link_url == 'http://') {
    $domain '';
    } else {
    // Get the original domain
    $parsed parse_url($child->link_url); 
        if (isset(
    $parsed['scheme']) && isset($parsed['host'])) {
    $domain $parsed['scheme'] . "://" $parsed['host'];
        } else {
    $domain '';
  14. narc

    narc Well-Known Member

    it works, but i have no button to the next step. link_table are full with my articles. only this:
    i have manuel edit http://localhost:8080/hotaru/admin_index.php?page=plugin_settings&plugin=pligg_importer&step=2 to 3. import is done, nothing errors. tag import habe the same errors a link_table.
    i edit http://localhost:8080/hotaru/admin_index.php?page=plugin_settings&plugin=pligg_importer&step=2 to 5.

    if i push 'continue', i become new error

    i cant to log in to hotaru - next step. new install on my localhost :(
    Last edited: Aug 13, 2010
  15. Nick

    Nick Well-Known Member

    Maybe this plugin is incompatible with Pligg 1.1? I don't know. I haven't used Pligg for three years.
  16. narc

    narc Well-Known Member

    Pligg sucks :(
    how much it would cost me "Pligg importer" for Pligg 1.1 update? beautiful it is when "Pligg importer" includes the article pictures would import into the hotaru.

    ps: again with the craft of custom template for hotaru with dummy data. for my new community here in the new forum. :)
  17. Nick

    Nick Well-Known Member

    Hi narc, thanks for providing me with a copy of your database. I ran the Pligg Importer plugin the usual way and was successful until importing the Users table. After the Users table was imported, I got kicked out of Hotaru because my cookie details don't match the record for the "narc" god user. It should work for you, though.

    I'm 99% certain that when you tried importing the Links table, it timed out. That's why it didn't show the "Continue" button.

    In php.ini in WampServer, part of my settings look like this:

    ; Resource Limits ;

    max_execution_time = 2700 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    ;max_input_nesting_level = 64 ; Maximum input variable nesting level
    memory_limit = 128M ; Maximum amount of memory a script may consume (128MB)

    2700 seconds is 45 minutes. Make sure yours is the same and run the import again. Ignore those parse_url warnings.

    Good luck! :)
    narc likes this.
  18. narc

    narc Well-Known Member

    hi nick. many thanks. Your tip does work and is the solution of my problems. you make my day. :)
  19. Nick

    Nick Well-Known Member

    Note: The Pligg Importer plugin no longer works with the latest versions of phpMyAdmin and is one heck of a memory hog. Please use the Pligg2Hotaru plugin instead. [​IMG]
Thread Status:
Not open for further replies.

Share This Page