1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Seo Friendly Urls - What Am I Doing Wrong?

Discussion in 'General Troubleshooting' started by wildgemma, May 30, 2014.

  1. wildgemma

    wildgemma New Member

    Hi guys

    Did do a search for the answer but couldn't find one. I renamed the .htaccess_default file as instructed but the readme also says follow instructions in that file which I couldn't see any, am I missing something?

    Activated the friendly option (through phpmyadmin as my settings page doesn't save, posted about this in another thread) but when I go to my site, it will only display the homepage.

    Have cleared the site cache through the admin panel and also my browser cache, cookies, history, etc but still the same.

    I know it's something to do with the actual .htaccess file since I've left it unchanged but what am I meant to be editing?

    Thanks!
     
  2. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    Your site is looking really nice. I like it

    can you paste a copy of your .htaccess file and also maybe a screen shot of your FTP folder showing the location of the .htaccess file? Which host company are you with?

    the friendly urls should definitely work with the standard .htaccess file provided. I am sure we can find the answer
     
  3. wildgemma

    wildgemma New Member

    Thanks shibuya246 =) I first tried the default, unedited .htaccess file that comes with Hotaru but no luck. Then I Googled for an alternative settings again nothing worked.

    I've used .htaccess files on my server before and it works. I wonder if it's because it's a sub-domain? My main site is www.pinkgarden.co.uk and I have a couple of registered domains running from it, all with their own URL address, such as www.indiehandmade.co.uk and www.ourcraft.co.uk. The folder structure is public_html/ourcraft.co.uk and this is where the .htaccess file resides. All the Hotaru files sit in the same main ourcraft.co.uk folder, not a subfolder within.
     
  4. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    If the .htaccess is in the same folder as the hotaru files then it should work
     
  5. wildgemma

    wildgemma New Member

    Hehe, it should but it don't. Not for me (and some others) any way :)

    As I mentioned before, am I supposed to change something within the .htaccess file? The readme file that comes with Hotaru says the following:

    Friendly URLS
    -------------

    If you want to use friendly urls, rename `htaccess_default` to `.htaccess`, and edit it according to the instructions within
    the htaccess file. Then go to Admin -> Settings and change the *friendly urls* setting to true.


    But there are no instructions within the .htaccess file so I haven't a clue if I did need to change any thing and what to change?

    My site is almost ready to go but I was hoping to have the friendly URLs up and working before I started pushing it.
     
  6. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    It may be due to the subdomain issue. You might want to try putting the htaccess file in the subfolder section
     

Share This Page