1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to register

Discussion in 'Installation and Upgrading' started by twine, May 8, 2010.

  1. twine

    twine New Member

    When I go through the install process I get to step 4 and try to register as admin. When i enter credentials and click on the UPDATE button it takes me to a page with these three messages:

    1. You are the owner of this web site and you have not uploaded (or incorrectly uploaded) your web site. For information on uploading your web site using FTP client software or web design software, click here for FTP Upload Information.

    2. The URL that you have entered in your browser is incorrect. Please re-enter the URL and try again.

    3. The Link that you clicked on incorrectly points to this page. Please contact the owner of this web site to inform them of this situation.
     
  2. Nick

    Nick Well-Known Member

    Are you using a .htaccess file? If so, something in that file is most likely the cause.
     
  3. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    Sounds like your installation of Hotaru worked fine, but your server setup has a problem pointing to the folder you have installed Hotaru in.

    Did you install to a sub folder or the root folder?
    Have you edited the htaccess file at all?
     
  4. twine

    twine New Member

    It's a sub folder off. I'm hosting on godaddy, so there is a primary domain. The one I'm trying to install on is alias. So it's www.maindomain.com/subfolder/hotaru

    Does it have to be done on a root?
     
  5. Nick

    Nick Well-Known Member

    Are you using a .htaccess file? If so, something in that file is most likely the cause.
     
  6. twine

    twine New Member

    the only htaccess file I see is the one in the Hotaru folder. htaccess_default.

    Does this need to be removed?

    Sorry I'm a total newbie at this type of stuff.

    BTW, thanks for the lightning fast responses. Great support.
     
  7. Nick

    Nick Well-Known Member

    No, you don't need to remove that. Can you confirm that the BASEURL setting in hotaru_settings.php is exactly "http://www.maindomain.com/subfolder/hotaru/" ? (with your own domain, of course).
     
  8. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    If you got to step 4 then your database has been setup ok. There may be a problem with your BASEURL setting. Can you tell me what you typed in for BASEURL ?
     
  9. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    I have written a different install file which might help you get passed Step 4 and then work out the problem with BASEURL after.
    Can you download the attached zip, unzip it and save the contents to your 'install' folder.
    then run /install/install.php

    You should choose 'New Installation'
    Step 1 should help you put in the baseurl. You may need to edit this still though

    then work through steps 3 and 4. you can type 'DELETE' to the db step if you only have a new installation since you have no data to lose as yet.

    let me know how this works. I am still testing this script at my end on different sites.
     

    Attached Files:

  10. twine

    twine New Member

    The BASEURL was typed in. I'm going to try again and see if I can fix. I'll keep you posted. Thanks again for all your help.
     
  11. twine

    twine New Member

    The good news is that I got Hotaru installed and working, however the redirect isn't working. I'm with GoDaddy so I have a primary domain and then several domains under that primary in folders. I used 'http://mysite.com/subfolder/hotaru' as the base URL. However the domain I want to use is associated with the subfolder and is not pointing to the site. Am I missing something in the htaccess file? I changed the rewrite line, but no luck. Any suggestions?
     
  12. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    the baseurl should be the URL users will type into their browser to access your site, not the internal godaddy path.
     
  13. twine

    twine New Member

    I had tried that with a previous installation and it wouldn't work. I'll try it again.
     
  14. Nick

    Nick Well-Known Member

    Don't forget the BASEURL should have a "/" at the end.
     
  15. twine

    twine New Member

    tied both ways and the only time it works is when I put in the direct path to Hotaru folder in the settings. When I put the URL I want to use into the BASE URL it doesn't go beyond step 4 and even the set-up interface looks different. None of the images render. When I use the direct path the UI renders properly but I can't get to the site through the url I want to use.
     
  16. twine

    twine New Member

    Hey guys,
    Was anyone able to come up with any thoughts on the problems with the redirect?
     
  17. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    Can you tell us your URL with godaddy that is supposed to be referencing the hotaru base pages?
    Try putting a simple text.txt file with something like "hello" in the base folder and then try to access it from the browser. does it appear?
     

Share This Page