1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

User Manager 1.6

User Manager

  1. shibuya246

    shibuya246 Hotaru Developer Staff Member Admin

    you wont need the csrf key for the filter so just cut that off and it should work
     
  2. vetsols

    vetsols Active Member

    Believe me, I use them, BUT I also like to give info to stopforumspam.com at the same time. My server was breached a few months ago and before I knew it, there was OVER 1 mill. spam mails sent from one of my sites.
     
  3. robin007

    robin007 Well-Known Member

    a user not able to login

    and I am not able to send random password

    please help.
     

    Attached Files:

  4. valMETNG

    valMETNG Administrator Staff Member Admin

    There's nothing wrong with that username so it might be that your plugins are out of order. Please check that plugins are in proper order. Also check if there are any errors in your error_log.php.
     
  5. robin007

    robin007 Well-Known Member

    I didn't get any error in error log

    only one user facing the problem.

    posts coming from other user continuously.

    That user name only have a hyphen symbol.
     
  6. valMETNG

    valMETNG Administrator Staff Member Admin

    Did you check the plugin order? Even though users are able to post, the plugin order still could be a problem. Unless you changed something, the hyphen isn't an issue as Hotaru allows hyphens in usernames.

    Please change line 724 in /plugins/user_manager/user_manager_settings.php to the following:
    Code:
    $userAuth->getUserBasic($h, 0, $username);print "user auth = ";print_r($userAuth);exit;
    Then try to resend the password and PM me the output if any of the user's information prints. (If nothing prints, you can just post that here.)
     
  7. robin007

    robin007 Well-Known Member

    I am getting this error
    Code:
    user auth = Libs\UserBase Object ( [id:protected] => 0 [name:protected] => [role:protected] => member [isAdmin:protected] => [adminAccess:protected] => [password:protected] => unknown [passwordVersion:protected] => 2 [email:protected] => [emailValid:protected] => 0 [loggedIn:protected] => [perms:protected] => Array ( ) [settings:protected] => Array ( ) [profile:protected] => Array ( ) [ip:protected] => 0 [lastActivity:protected] => 0 [loginType:protected] => [profileSettingsData:protected] => )
     
  8. valMETNG

    valMETNG Administrator Staff Member Admin

    Ah, I wonder if the problem is related to this. Please change line 724 to:
    Code:
    $userAuth->getUser($h, 0, $username);
    Then retry to send password.
     
  9. robin007

    robin007 Well-Known Member

    Thanks it's working :D
     
  10. valMETNG

    valMETNG Administrator Staff Member Admin

    Good to hear. @shibuya246, one more to add to the next release.
     

Share This Page