1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vote 2.3 2.5

Let users vote for posts

  1. norby500

    norby500 New Member Donor

    when somebody presses on broken link and reports the URL, what happens after it is reported, does it just auto bury? or does it flag up in my admin page to check it out? i am just curious how it works compared to people reporting it for being 'lame'?
     
  2. Nick

    Nick Well-Known Member

    It's the same as other flags. If you hover over the flag you can see the reason it was flagged, which is especially useful in the case of a broken link.
     
  3. norby500

    norby500 New Member Donor

    cool, i understand fully now, does this only show to admins or users? i was looking for somewhere that it reported it to, like a admin control section, but that's pretty cool :D, does it bury the post slowly when you hit broken link or does it just report it?
     
  4. Nick

    Nick Well-Known Member

    Everyone can see the reason something is flagged, and every alert adds to the total bury count as specified in the Vote settings ("Number of alerts to automatically bury a post").
     
  5. richrf

    richrf New Member

    Hi,

    Voting doesn't seem to be working any more on Links.com. It was working yesterday.

    Rich
     
  6. petsagouris

    petsagouris Design & Development

    Because the HTML currently outputted is bad,... there is an extra <script type="text/javascript">.
    I suggest you review your YOUR_THEME/header.php
     
    Last edited: Aug 31, 2010
    richrf likes this.
  7. richrf

    richrf New Member

    Thanks a lot! Yes, there was a remnant from the Google Analytics script that I inserted last week and then deleted when the GA plugin was updated with the current script. For now, I am going to leave everything alone and stand pat. Thanks again for your assistance.

    Rich
     
  8. jganesh

    jganesh New Member

    Hi,

    I did a fresh install of this cms on a different server and used the bookmarking plugin pack. I am not able to vote it. If i click on the Vote, it just add the "#" to the url. I thought it might be some jquery issue but jquery test plug in worked fine. also I removed the plugin and installed it again but no luck.

    please let me know if this is a known issue.

    update - In IE, I see some JS errors and it says "BASEURL" is undefined. so may be this is the issue? how to fix this? where to define baseurl?


    regards
     
    Last edited by a moderator: Oct 7, 2010
  9. Fireteo

    Fireteo New Member

    Add baseurl in hotaru_settings.php ( in the main folder)
     
  10. jganesh

    jganesh New Member

    thanks but I already have it there. not sure if this is defined somewhere else to.
     
  11. Nick

    Nick Well-Known Member

    No, it's not a known issue. Tell us your url so we can have a look.
     
  12. jganesh

    jganesh New Member

    i got it, sorry to post the question without debugging it well. I figured it out and it was related to the jquery $ symbol. I had to change it to "jquery" in the vote js file.

    One thing that's still not working is the "Automatically count a users vote when they click on the URL link". Any idea?
     
  13. Nick

    Nick Well-Known Member

    If you give us a link we can find the error with Firebug.
     
  14. skorpyo

    skorpyo Well-Known Member

    how can I add images to the voting buttons?!
     
  15. Nick

    Nick Well-Known Member

    Something like this in vote.css:

    PHP:
    .vote_color_top 
        
    background-imageurl(../../../content/themes/YOUR_THEME_NAME/images/top.png);
        
    background-repeatno-repeat;
    }

    .
    vote_color_new 
        
    background-imageurl(../../../content/themes/YOUR_THEME_NAME/images/new.png);
        
    background-repeatno-repeat;
    }
     
  16. skorpyo

    skorpyo Well-Known Member

    As my site has that problem...I can't test this for now. But thanks for the code, I had a similar approach...
     
  17. angolanmade

    angolanmade Well-Known Member

    Haven't fully tested this, but i think if you submit a post without a url/link that the option to automatically increase vote count when clicking a post link doesn't work?
     
  18. rpermana

    rpermana Donor Donor

  19. seekyt

    seekyt Donor Donor

    My vote has been working perfectly for months until suddenly today.

    I have been making some template edits on my site, and I'm not sure if it has anything to do with it, but as someone pointed out before me, now the vote number does not change on click, and a simple "#" is added to the URL. Auto vote seems to be working fine.

    My website is the same as my username with a .com after it :) I'm not getting any errors (that I can tell, at least) in the error log.

    I hope someone can point me in the right direction

    EDIT*** Nevermind, I found the problem. I had moved the Google 1.4 js call to the bottom of header.php to defer it's loading (page speed rules). I moved it back and now it's working again. Thanks!

    P.S. - I have tried clearing the cache, reinstalling the plugin, switching to up-down voting, etc. Nothing seems to work.
     
    Last edited: Jan 12, 2011
  20. done

    done New Member

    Does anyone know how to change the javascrip to autovote when you click on a link from the list page to the post page, rather than from the post wage to the external link?

    here is (I think) the relevant code:
    Code:
    if ($('#loggedIn').hasClass('loggedIn_true')) {
                $(".show_post_title a").click(function(event) {
                    if (vote_on_url_click == "checked") {
                        if ($(this).hasClass('click_to_source')) {
                            event.preventDefault();
                            var post_id = $(this).parent().parent().attr("id");
                            var parts = post_id.split('_');
                            post_id = parts[parts.length-1];
    
                            vote( post_id, 10, 'link' );
                            link = $(this).attr('href');
    
                            setTimeout(function () {
                                window.location.href = link
                            }, 500);
                            return false;
                            }
                        }
                        return true;
                });
           }

    OK figured it out, delete if ($(this).hasClass('click_to_source')) {
     
    Last edited: Jan 15, 2011

Share This Page